Friday, 3 October 2014

Realtek HD Audio speakers and headphones with separate volume

So what's this article about? Well..

I recently updated my audio driver from the default built in Windows 8.1 device driver to use the Realtek audio driver and it also installed the Realtek HD Audio Manager.  It's a nice bit of software that allows you configure all things audio.

However, as soon as I installed it I noticed that, when I plugged my headphones in, the volume was deafening.  This was because the volume slider in the system tray was being shared between headphones and speakers.  Previously when I plugged the headphones in, it muted the speakers and switched over to my headphones at around 15% volume.

Now when I plug my headphones it it's at 100% still, which is what the speakers were at, needless to say it's a bit of a shock every time.

I found out however that there is a solution. If you start the Realtek HD Audio Manager, there's usually an icon in the system tray, you can go to "Device advanced settings" in the top right corner and choose "Make front and rear output devices playback two different audio streams simultaneously".

Now plug your headphones in and you get a second tab appear in the tool, one which is the "Speakers" and in my case "HD Audio 2nd output" which was my headphones.  I set the headphones as the default device by clicking the "Set Default Device" button just to the right of the volume slider in the tool.  This means that when I unplug the headphones the system falls back to the only other device, the speakers, and remembers what volume it was on, i.e. 100%.

Then when you plug the headphones in again, it recognises them and switches over to them being the default device and importantly remembers the volume setting that was last used. No more deafness!

4 comments:

  1. Cool, if it worked in all the cases.
    Unfortunately on my Fujitsu LifeBook e-Series it doesn't.
    Even if I do what you suggest, the new headphones tab that you describe does not appear. Actually the window blink but nothing happens. :(

    ReplyDelete
    Replies
    1. Grr how frustrating. Sometimes I think about dropping back to the stock drivers without all the management software, but it's not ideal...

      Delete
    2. I had to do this again today after an OS reinstall, and I found I had to quit the Realtek HD Audio Manager after setting the advanced settings and start it again, then plug the headphones in. The second tab didn't appear if the app was still open.

      Delete
  2. This comment has been removed by a blog administrator.

    ReplyDelete